Symptoms
When using Google Sheet triggers in your Zap, the Zap does not run even though the spreadsheet was updated. Your Zap is turned on, but there is no corresponding Zap run in your Zap history.
Causes
This happens when you make any of the following structural changes to your spreadsheet:
- Delete existing rows or columns.
- Add rows anywhere other than to the bottom of your sheet.
- Sort your worksheet.
- Rename, add, or rearrange columns.
- Rename your spreadsheet or worksheet.
- Add frozen, hidden, or protected columns or rows.
Any of these changes will break the connection between Zapier and your spreadsheet.
How to fix it
To fix this:
- Turn your Zap off.
- Update your spreadsheet.
- Re-test your Google Sheets triggers or actions in any connected Zaps. Depending on the changes you made, you may need to remap fields.
- Turn the Zap on again.
- Before making any structural changes to your spreadsheet, you must repeat this process every time you or a teammate updates the spreadsheet.
- Alternatively, you could switch to using another spreadsheet app such as Zapier Tables. Zapier Tables lets you use your table in the following ways without affecting your Zaps:
- Create views or filters to display subsets of a table’s data.
- Trigger and continue Zaps from records, either manually or automatically when a record is created or updated.
- Add rows anywhere within a table.
- Delete rows within a table. However, deleting a column used in your Zap will cause it to break.