Zap is creating duplicate data

When testing your Zaps or when they run live, you notice that data sent to one or more connected apps is duplicated.

Causes

This can happen for the following reasons:

  • Using static values instead of dynamic values.
  • Broad trigger settings.
  • Multiple Zaps are using the same trigger.
  • Unintentional Zap loops.
  • Timeouts.

How to fix it

  1. Go to your Zap history
  2. Search for affected Zap runs using a unique identifier that is duplicated across multiple records, such as an ID or email address. 
  3. Review multiple Zap run details
    • This will show you where data is being received and sent at each step, helping you to find which part of the Zap is causing the issue.

Following these steps should help you identify the cause of the duplicated data and determine your next step. 

Using static values

Using static values

When setting up a Zap, it’s common to test a field by typing static text into it. However, once the Zap is on, you likely want that field updated with dynamic values. You might forget to update your Zap accordingly. To correct this:

  • In your Zap, go to your affected action.
  • Replace the static text with dynamic values (mapped fields).
  • (Optional) Repeat these steps for all affected action steps.
Broad trigger settings

Broad trigger settings

If your Zaps are triggering from unwanted data, you may need to refine your trigger.

Try the following:

  • Adjust the settings in the app that trigger your Zap. 
    • Where supported by your app, change its settings to filter data before it reaches Zapier. For example, in Pipedrive, you can change your deal filter settings using the Deal Matching Filter trigger.
  • Modify your Zap’s trigger or its settings. 
    • Review whether the trigger you’re using has fields you can use to filter data, or if there’s an alternative trigger you can use instead.
    • For example, in the New or Updated Spreadsheet Row trigger for Google Sheets, you can define which columns to trigger from instead of triggering from any update to a row.
  • Add a Filter to stop the Zap from continuing unless it meets certain conditions.
  • Use a find or create action in your Zap. If your app supports it, use a find or create action to ensure new data is only made if it does not already exist. 
    • For example, with HubSpot’s Find or Create Deal action, you can search for an existing deal, and if one is not found, create one instead.
Multiple Zaps using the same trigger

Multiple Zaps using the same trigger

If multiple Zaps are using the same trigger data, try the following:

  • Add a Filter to stop the Zap from continuing unless it meets certain conditions.
  • You can also use Paths to combine multiple Zaps with different outcomes.
Unintentional Zap loop

Unintentional Zap loop

If you have one Zap causing the issue, it could be caused by an unintended Zap loop. This can happen when a Zap performs the same action that also triggers the Zap. For example, if the Zap triggers from a new spreadsheet row and the action is to create a new spreadsheet row in the same spreadsheet, the Zap will loop. 

Learn more about Zap loops and how to fix them.

Timeouts

Timeouts

If you find a “timed out” error message in your Zap runs, any attempts to replay the errored action may be creating duplicate data.

Learn more about timeout errors and how to fix them.

If the duplicates persist, contact Zapier support. Include links to:

  • The most recent Zap runs that created duplicate data.
  • Full-page screenshots of the duplicate data in your connected apps.
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