Symptoms
Your Zap errors and has a stopped status in your Zap history. Typically, there is a large volume of Zap runs with this status.
You might see one of these error messages in your Zap run details:
- "Too much data received for one task (... bytes), Zapier has blocked this task."
- "Too much data received (... * ... bytes) within a ... second window, Zapier has blocked this task. Resets in ... seconds."
- "Throttled by Zapier! Max ... runs per ... seconds."
Causes
This happens when your Zap makes too many requests to Zapier or a connected app within a short period of time, resulting in a rate limit being exceeded. The limit is imposed either by Zapier or the app.
How to fix it
To fix the issue:
- Review the Zap rate limits article. This will help you determine if this is a Zapier or app-related issue.
- If the message mentions a second window or a maximum number of runs per second, replay the Zap run.
- Add a delay after queue step to your Zap, which holds actions for a specific time before running them.
- Zapier paid plan users can adjust the flood protection limit on your Zap.