Symptoms
When using a HubSpot search action in your Zaps, you get the error message "Nothing could be found for the search." You’ll see this error in the details of a Zap run in your Zap's history. The object you are searching for may exist in HubSpot.
Causes
This happens when:
- The object you are searching for does not exist in HubSpot.
- The search criteria for an object property does not match the corresponding data in HubSpot.
- The selected property type might be incorrect.
- The mapped field from the previous step is blank.
- HubSpot requires values to complete the search.
Example
You are searching by a contact’s first name, and the mapped field contains the first and last name. The search will fail as the data in Hubspot does not match.
How to fix
To fix this:
- Check in HubSpot that the object you are searching for exists.
- If it does not exist and is required for your Zap, amend your HubSpot search action to create that object in HubSpot.
- Review your HubSpot search action. Ensure the property type you selected to search by is correct and matches the corresponding data in HubSpot.
- Learn more about HubSpot’s properties.
- Check the mapped field you are using in your search field. You may need to select a different one to match how the object is identified in HubSpot.
- If no data comes through your mapped field, replace it with a field that consistently provides a value. If you cannot change the current mapped field:
- Add a step to set a default value as a fallback whenever your mapped field has no data.
- Add conditional logic using a filter or branching logic with paths to your Zap. This will allow you to define what the Zap should do if the mapped field receives no data from the previous step.
- (Optional) You can format data in your mapped field using Formatter by Zapier to match what HubSpot expects. Learn more about:
- If no data comes through your mapped field, replace it with a field that consistently provides a value. If you cannot change the current mapped field: