ChatGPT error: Nothing could be found for the search

Symptoms

When using the ChatGPT Find Assistant action, you see the error message, "Nothing could be found for the search". You will see this error in the Zap editor when you test your ChatGPT step or in Zap history after your Zap runs. 

Causes

This can happen when:

  • You attempt to search for an Assistant created in the Assistant playground.
  • You attempt to search for a GPT. While GPTs are similar in functionality to Assistants, GPTs can only be used with AI actions. Learn more about the difference between GPTs vs Assistants.
  • You have more than 500 Assistants in your OpenAI account. Zapier is only able to find the first 500 Assistants created in your OpenAI account.

How to fix it

To fix the issue:

  1. To use your existing GPT with Zapier, you must use AI Actions.
  2. To use an Assistant in your Zap: 
    1. You must recreate your GPT. You can do this by using the Create Assistant action.
    2. Once created, you will be able to search for your Assistant in the Find Assistant action.
    3. Learn more about using Assistants in your Zaps.
  3. If you have more than 500 Assistants in your OpenAI account:
    1. Go to the OpenAI Assistants.
    2. Delete any unused Assistants. 
      • If your account belongs to an organization, check with your teammates to ensure you do not remove any Assistants that are still in use.
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