I cannot see login options on my interface settings

Symptoms 

When looking at Access & User settings for an interface, you cannot see any login options:

  • Magic Link
  • Google
  • Approved Domains

 

Causes

This can happen for two reasons:

  • You're on a Basic (free) Interfaces plan.
  • You're using the legacy version of managed users.

 

How to fix it

Change your Interfaces plan

If you're on the Basic (free) plan, you will not be able to use any of the login options. Only paid plans can create interfaces with protected access. You can change your Interfaces plan to get access to these features.

 

Note

Login with Google is only available on the Advanced plan.

 

Switch to the newer version of the managed users feature

The legacy version of the managed users feature does not offer the magic link, or login with Google options. To check which version you're using and move to the newer one:

  1. From the Interfaces home, click the name of your interface.
  2. Click the Settings button at the top of the screen.
  3. Click Access & Users in the left sidebar.
  4. Check the selection in the Access dropdown menu. 
  5. If it says Managed users only (legacy), click the dropdown menu and select Managed users only (new) to move to the new version.
  6. In the dialog box that will appear, click Yes to confirm you're aware that Table and Kanban components will be reset.
  7. The Login options section will appear. Click the toggle on or off for the options you want to use.
  8. Click Save changes.

 

Note

When you move from the legacy version to the newer version of the managed users feature, your user list will be removed. You must re-add all users to the interface.

Was this article helpful?
0 out of 0 found this helpful