Zap filters are not working properly

Your Zap contains a filter, but it does not follow the filter's conditions when it runs. As a result, the rest of the Zap does not run as expected. The Zap run status shows as Filtered in the Zap history.

In your Zap run, you may see also (missing value) where the field data should be.

 

Causes

This can happen for different reasons:

  • Mismatched field data: The mapped field’s name changed since the Zap setup, causing the previous mapping to fail. 
  • Missing data: The app did not send any data to Zapier. This will appear in the Zap run as (missing value).
  • Incorrect filter condition: Your filter condition did not match your intended goal. For example, you selected AND+ when you meant OR+.
  • Mapped field data contains whitespace: Whitespace refers to non-visible characters (like spaces, tabs, and newlines) that affect text formatting and positioning. Though not visible when reviewing your data in Zapier, these characters can be present in mapped fields.

How to fix it

To fix this issue:

  • View the Zap run details. In the trigger or action step where you’re mapping a field from, review the Data Out tab to check how the data was sent to Zapier. 
    • To check for whitespaces, highlight the field by clicking and dragging your cursor over the text. This will make extra white spaces more noticeable.
    • If you find (missing value):
  • Review the Filter and path rules in Zaps
    • Check if your filter follows the right condition based on the type of data. 
      • Certain filter rules work better with text, while others are meant for numbers.
    • Check you are using the AND or OR logic correctly.
    • If you have multiple paths, check if the path rules work as intended.
    • When filtering on dates, check that the value is the same format as the condition.
  • Test your Zap: Get a new test record and re-test your filter to ensure it works as expected with the correct mapped fields.

 

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