Zap field will not accept your data

When attempting to test your Zap step, or when your Zap is live, you notice that you receive an error referring to a value format.

Causes

This happens when the value (static or dynamic) does not match the app’s expected format.

actionEdit icon Example
  • Dates: An app expects a date formatted as “MM/DD/YY”, not “May 29, 2035”.
  • Using custom values: An app expects a field ID, not a field name.
  • Images: An app expects a file object or publicly-accessible URL, not the name of the image. 
  • Invalid email address: An app expects a real and valid email address, not a fake email address. 

How to fix it

  • Go to the Configure tab of your affected Zap step.
  • Review the affected field to identify its expected format. 
  • Review the field’s help text (if applicable).
    • If a field has a dotted underline, this means it has help text. 
      • Click the field name to display the help text. Often, help text contains the expected format and examples of what it expects.
    • If the field does not have a dotted underline, it does not have help text.

Once you’ve identified the expected format and any specific app instructions from the help text, enter the value in the format your app expects.

Choose the scenario below that best matches your situation for further advice:

Modify field values

Modify field values

If the fields available in your Zap still do not match the app’s expected format, you can use the Formatter app to transform the field values: 

  • Date and time: Modify date and time formats
  • Numbers: Adjust number formats.
  • Text: Convert letter casing, remove extra text, and extract data like email addresses.
  • Utility: Create line items or transform line items to text strings. 
Mapping fields as custom values

Mapping fields as custom values

If you are having trouble using a custom value:

Sending images in Zaps

Sending images in Zaps

If you are having trouble sending an image in a Zap:

  • Confirm the field type. Likely, the field you are using is a file type
  • There are 2 ways to send image to a file field: 
ratingStar icon Tip

The field help text will usually include specific guidelines on what image file types are expected in the help text.

Invalid email address

Invalid email address

You can validate email addresses in your Zap using these options:

  • Add an email verification action using apps like NeverBounce and ZeroBounce.
    • (Optional) Once you have a email verification step, add a filter step. Use this filter to process the results from your verification step to ensure your Zap only runs with a valid email address. 
  • In your app’s settings, set up email validation rules or add help text to guide users to enter valid email addresses (if applicable).

Still need help? 

If this article did not fix the issue, Zapier has a few other options to get you the help you need:

Was this article helpful?
7 out of 22 found this helpful