If a specific app stops working in your AI client when using Zapier MCP, the app connection on your MCP server likely needs attention.
Symptom
A specific app is not working in your AI client. An alert icon appears next to the app on your MCP server.
Causes
- The app connection has expired and needs to be reauthenticated.
- The app's API permissions were revoked from the third-party service.
- The tool is misconfigured on your MCP server.
How to fix it
- In the left sidebar of the Zapier MCP dashboard, select your server.
- Find apps with an alert icon beside their name.
- Select the menu icon beside the app name.
- Select Update authentication and follow the prompts.
This updates the connection for all tools using that app. Learn more about managing tools for your MCP server.
Still need help?
If this article did not fix the issue:
- Ask in the Zapier Community for advice from experienced Zapier users.
- Contact the Zapier MCP team for feedback or help.
- Learn more about getting help and support with Zapier.