Symptoms
When using Slack’s search action in your Zaps, you get the error message “Nothing could be found for the search.” You’ll see this error while testing your Slack step or in the details of a Zap run.
Causes
This happens when:
- The message you are searching for does not exist in Slack.
- The search query does not match the corresponding messages in Slack.
- The search modifiers restrict your search results or have been set up incorrectly.
- The mapped field used to identify the username contains blank spaces (whitespace).
How to fix
To fix it:
Find Message action
- For your affected Zap run, check the message you’re searching for exists in Slack.
- Go to your affected Slack step.
- Check the Search Query field to ensure it uses supported Slack modifiers.
- Ensure the Sort By field is set up for your expected results.
- Match Strength (sort by most relevant message)
- Message Date Time (sort by most recent message)
- Check that the Sort Direction field is set the way you expect.
- Descending (most recent or best match first)
- Ascending (oldest or worst match first)
Find Username action
This search action often errors because there are white spaces within the field mapped. To check for white spaces:
- Go to your affected Zap run.
- Click the action step where the mapped field with the username comes from.
- Review the Data Out tab.
- To check for white spaces, highlight the field by clicking and dragging your cursor over the text. This will make extra white spaces more noticeable.
- If the field contains additional white spaces, you can add a Formatter step to remove extra text.
Note
You can use the procedure of highlighting the content of a field to check for white spaces when testing the step.