Google Drive error: Nothing could be found for the search

Symptoms

When using either of the Google Drive search actions (Find a File or Find Folder) in your Zaps, you see the error message "Nothing could be found for the search". You may see this error when setting up a Zap or in the details of a Zap run in your Zap history. 

Causes

This happens when: 

  • The mapped field from the previous step in the File Name or Folder Name field is blank. 
    • Google Drive requires values in those fields to complete the search. 
  • The value in the File Name or Folder Name field does not exist in Google Drive. 
    • In some cases, the creation of a file or folder depends on another Zap that has not run at the time the search was carried out.
  • The search for a file could not be completed because it does not meet the search criteria selected in the File Types dropdown menu.

How to fix it

To fix this issue:

  • Ensure the data from the previous step is consistently sent to the Google Drive step, or replace the current mapped field with one that consistently provides a value.
  • If you have a file or folder that exists but is in a different folder than what is selected in the Zap, try clearing the Folder or Parent Folder field.
  • If the file exists, but the search is unable to find it, try clearing the File Types dropdown field.
  • If you cannot change the current mapped field, you can either:
    • Add a step to set a default value as a fallback whenever your mapped field does not have any data.
    • Add conditional logic using a filter or branching logic with paths to your Zap. This will allow you to define what the Zap should do if the Filename or Folder Name fields receive no data from the previous step.
  • Add a delay to your Zap to add in some time before the Zap searches for the file or folder.
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