Symptoms
When you use a create or update action in a Google Sheets step, you see an error message of "There was an error writing to your Google Sheets, unable to parse range". This happens when testing the Zap or if the Zap is live.
Causes
This can happen for a few reasons:
- A column in the sheet has been removed.
- The sheet has been renamed.
- Insufficient permissions.
- Some of the rows or columns are frozen, hidden, or protected.
How to fix it
To fix this:
- Check the sheet name and the range of columns and rows used by your Zap to ensure it matches what you see in Google Sheets.
- If a field is empty or missing items follow this tutorial.
- Verify that the Google account connected to the Zap has editor permissions for that sheet.
- Check if any rows or columns being used by the Zap are frozen, hidden, or protected in Google Sheets. Adjust them, if necessary, as Zaps cannot work with frozen, hidden, or protected columns and rows.