Symptoms
Your Zap uses the Facebook Lead Ads New Lead trigger but it does not trigger even though you receive new leads in your Facebook account. Your Zap is turned on but there are no corresponding Zap runs in your Zap history.
Causes
This happens when:
- Your account has insufficient account permissions to use Facebook Lead Ads in Zapier.
- You have selected the wrong Facebook Lead Ads form in your Zap.
- You update your form. Facebook assigns a new ID to updated forms, meaning the previously selected form is no longer valid.
How to fix it
To fix this issue:
- Upgrade your Facebook Lead Ads account permissions.
- Reconnect your Facebook Lead Ads account after you upgrade your permissions.
- In your Zap, re-select your form from the dropdown menu.
- In your Zap, test your Facebook Leads Ads trigger step to confirm that Facebook Lead Ads is sending valid data from your form.
- (Optional) If you do not have any new leads, create a sample lead using the Facebook Lead Ads testing tool.
- (Optional) Transfer existing leads using a one-time transfer.