Symptoms
Your chatbot answered questions incorrectly or provided incorrect information when interacting with users.
Causes
Inaccuracies (incorrect information) and hallucinations (made-up information) can occur in AI chatbots for many reasons. They may be due to insufficient data or to the way the model is trained.
How to fix it
- Ensure you provide your chatbot with clear instructions so that it can handle most questions. Use this template to get started.
- Use knowledge sources to give the Chatbot more context around the topics you want it to focus on.
- Lower the Chatbot creativity level. This can help it stick with known information.
- Use an advanced model. A more advanced model may offer improved reasoning and context. Learn how to connect a different model using your own OpenAI API key.
- Zapier Chatbots are designed to answer straightforward questions. If you want to get insights or perform analysis on a file, try using Zapier Agents.