Symptoms
When using the Send Email action, Zapier might display an error message: “Email by Zapier: Sorry! That is too many emails sent. Please try Mandrill, Mailgun, Gmail, or others for bulk email”. This usually occurs when the Zap is turned on.
Causes
This happens when the Email by Zapier app limits the number of emails you can send within a specific timeframe to prevent spam. The allowed email limit per hour depends on your Zapier plan:
- Trial or Free plan: 5 emails per account per day.
- Any paid plan: 10 emails per account per hour.
How to fix it
To fix the issue, follow these steps:
-
Review your trigger settings:
- Check if you can adjust the frequency of your trigger. Some triggers may allow you to refine when your trigger should run.
- Use an alternative trigger in your Zap.
- Upgrade your Zapier paid plan: This will increase your limit to 10 emails per hour. This is a good option if you regularly need to send more than 5 emails per hour. Learn more about changing your Zapier plan.
- Use an alternative email app: If you need to send more than 10 emails per hour, consider using a different email app, such as Mailchimp Transactional, Mailgun, or Gmail. These apps typically offer higher sending limits and may be better suited for bulk-sending emails.