Symptoms
When using Webhooks triggers in your Zap, you may encounter one of the following issues:
- The trigger may not retrieve test records, preventing you from testing sample data.
- The Zap may be turned on but does not trigger when it should.
Causes
This can happen for a number of reasons:
- The app sending the webhook may have incorrect settings or may not be sending webhooks to Zapier.
- The webhook data format might be incompatible with Zapier or improperly structured, causing Zapier to fail to process it.
- Payload data must be in XML, JSON, or form-encoded formats.
How to fix it
1. Retest your trigger
Start by testing if your Zap can pull in test records to confirm Zapier is listening for webhooks.
- In your browser, open your app in one tab or window, and your Zaps’ webhook trigger step in another.
- In your app, perform the event that will trigger the webhook (such as creating a record).
- Go to your Zapier tab. In the Test tab, click Test trigger.
- For instant triggers, you must test immediately after performing the trigger event. Delays may cause Zapier to miss the trigger. If this happens, you must repeat the trigger event before re-testing in Zapier.
If you are able to pull in a test record, it confirms that Zapier is able to receive webhooks from your app.
If you are unable to pull in a test record, your webhook may not be configured correctly.
2. Generate your own API request
You must create a webhook request to determine whether the issue is with the Zap or the app. Zapier recommends using a tool such as Postman to create a custom HTTP request.
- In a new tab, go to Postman.
- Create an API request using the POST API method and copy the Webhook URL from your Zap.
- In the Body, add the payload data of the request.
- Payload data must be in XML, JSON, or form-encoded format only.
- Click Send.
- In your Zapier tab, go to your webhook trigger, and in the Test tab, click Test trigger.
If you're using curl or hurl.it, use a POST request with a JSON payload. Here's a curl example:
curl -v -H "Accept: application/json" \ -H "Content-Type: application/json" \ -X POST \ -d '{"first_name":"Bryan","last_name":"Helmig","age":27}' \ https://zapier.com/hooks/catch/n/Lx2RH/
If you can send data to the Zapier webhook URL, it confirms that the app needs to be configured to send data to Zapier. Go back to your app to review the current settings to ensure:
- You are using the correct Zapier webhook URL.
- You are able to use webhooks in your app.
- The payload data is in a supported format.
If you’re unable to send data to the Zapier webhook URL, you must investigate the issue further.
3. Inspect the request data
To see if the webhook is being sent and how your app formats the data, you can inspect the request outside of Zapier. Tools like Webhook.site can help with this.
To use this site:
- Go to Webhook.site.
- Copy the unique URL from the testing site.
- Go to your app’s webhook settings.
- Enter the unique URL provided by Webhook.site as the destination webhook URL.
- In your app, perform the event that will trigger the webhook (such as creating a record).
- Once triggered, the app will send an HTTP request with the event data to your Webhook.site URL.
- In your Webhook.site tab, you’ll see the incoming request displayed in real time on the page. It will contain details about the requests.
If records appear, it confirms that your app is sending webhooks, but Zapier cannot process their data. This is often due to an unsupported payload format and requires pre- or post-processing. Instead of using webhooks, you can create an app integration using the Zapier Developer Platform. Learn more about using advanced webhooks in the Developer Platform.
If records do not show up, this means the app is not sending webhook data at all. Contact the app’s support team to see if they can confirm your webhook setup is correct.