If your Zap or step run is held, it can be due to several causes. This article explains how to troubleshoot held runs.
Causes
Held statuses can be caused by:
- Too much data: when Zapier checked for new data, too many steps (100+) were triggered. This is called “flood protection" and prevents your Zap from accidentally using a large number of tasks.
- Disconnected app: one of the app accounts used in the Zap is disconnected.
- Task limit reached: the account reached the task limit for its plan or used a premium appthat is not available in your Zapier plan.
- Payment issue: the payment information on the account expired and must be updated.
-
App access policy
: inTeam or Enterprise accounts
, the Zapier account owner or admin haslimited the use of the app
, and you do not have permission to use it. This can happen when:
- The app is on the account's restricted apps list (open policy).
- The app is not on the allowed apps list (closed policy).
- An admin switched from restricted apps to allowed apps, and the app was not added to the allowed list.
- Step limit reached: the Zap has more than 100 steps.
How to fix it
Too much data
Use a delay after queue action to run tasks at a slower pace. After your Zap triggers, it will add actions to the queue, which are then processed one by one in the order they were added.
Disconnected app
Reconnect the app account, then replay your held Zap run.
Task limit reached
Upgrade your Zapier plan, then replay your held Zap run.
Payment issue
Update your payment method, then replay your held Zap run.
App access policy
The solution depends on your account's app access policy:
- If your account uses restricted apps (open policy): Ask your account owner or admin to remove the app from the restricted list, or add an exception for your member account or team.
- If your account uses allowed apps (closed policy): Ask your account owner or admin to add the app to the allowed list.
- If your admin recently switched policies: The app may not yet be on the new allowed list. Ask your admin to add it.
Once the app is permitted, replay your held Zap run.
App access policies affect both Zaps and Agents. If an Agent uses an app that is restricted, or not on the allowed list, it may not run as expected.
Step limit reached
Split your workflow into 2 or more Zaps.