Microsoft SharePoint error: 404 FILE NOT FOUND

Symptoms

When using the Microsoft SharePoint Upload a File action in your Zaps, you see the error message "Error code 404: 404 FILE NOT FOUND". You may see this error when setting up a Zap or in the details of a Zap run in your Zap history.

Causes

This happens when:

  • The file you're trying to upload exceeds the maximum size is 10MB.
  • The provided file URL is not publicly accessible or downloadable.
  • The Site field contains an invalid URL format. It should only include the portion after /sites/.

How to fix it

To fix this issue:

  • Check that your file is 10MB or less.
  • Test that the file's URL is accessible or downloadable. 
    • Open an incognito browser and copy and paste the URL into the address bar. 
    • Press Enter on your keyboard.
    • One of the following will happen:
      • The file will display in the browser window if it’s a viewable format.
      • The browser will download the file to your computer.
      • If the file cannot be accessed or downloaded, you may see an error message. This means Zapier cannot access the file. Learn more about sending files in Zaps.
    • If the Site field is a mapped field with your SharePoint site's full URL, use a Formatter step to split the site name from the rest. The site name is the portion that comes after /sites/ on your URL. 
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