Mailchimp error: Invalid Resource - Please provide a valid email address

When using the Mailchimp Add/Update Subscriber action in your Zaps, you see the error message "Invalid Resource - Please provide a valid email address". You may see this error when setting up a Zap or in the details of a Zap run in your Zap history.

Causes

This happens when:

  • The mapped field does not contain a valid email address.
  • The mapped field contains more data than just an email address, such as the email address and a telephone number.

How to fix it

To fix this issue:

  • If the issue only occurs when you test the step, change the value to provide a valid email address.
  • If the mapped field contains more information than just an email address, add a Formatter step after it to:
  • If the mapped field contains data in an unexpected format, you can use regular expressions (regex) to extract the email address.
  • Before continuing to your Mailchimp step, add a filter to your Zap to ensure an email address exists in the field.

Still need help? 

If this article did not fix the issue, Zapier has a few other options to get you the help you need:

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