Symptoms
When using any of Pipedrive search actions in your Zaps, you see the error message "Nothing could be found for the search". You may see this error when setting up a Zap or in the details of a Zap run in your Zap history.
Causes
This happens when:
- The mapped field from the previous step contains text instead of an ID that Pipedrive expects.
- The mapped field data does not exist in Pipedrive when searching for text.
- You attempted to search for data within a custom field type that Pipedrive does not support. For searches, Pipedrive only supports text, large text, numerical, monetary, autocomplete, phone, and address type custom fields.
- You used an exact match search, which restricts your search results. This means it can be affected by the case, spelling, punctuation, spacing, special characters, and word order.
How to fix it
To fix this issue, in your Pipedrive search step:
- Ensure the Field to Search By field contains a supported field type and has not been set as a custom value.
- You can also create a lookup table with the relevant Pipedrive IDs to dynamically update the Field to Search By field using custom values.
- If you’re using exact match search, try using a broader search (fuzzy). This will allow the Zap step to find similar results such as closely related phrases or keywords. To enable fuzzy search:
- In the Search for an Exact Match? field, select No.
- If you must use exact match search, add a Formatter step to remove unnecessary formatting (e.g., extra spaces, special characters) from the search query to improve matching accuracy.