Zapier Tables error: Nothing can be found for the search

Symptoms

When using a Zapier Tables search action in your Zaps, you get the error message “Nothing could be found for the search.” You’ll see this error in the details of a Zap run.

Causes

This happens when:

  • The record you are searching for does not exist in the table, or another Zap that should create it has not yet created it.
  • The search criteria for a record do not match the corresponding data in the table, such as:
    • The mapped field in the Lookup Value field(s) contains data in a format different from that in Tables. 
    • The search operation type or number of Lookup fields set is overly restricting your search.

How to fix

To fix it:

Check that the record you are searching for exists

  • If it does not exist, amend your search action to create a record if it cannot find one:
    • Go to your Zapier Tables search action.
    • In the Configure tab, select Create Zapier Tables Record if it doesn’t exist yet? checkbox.
    • Complete any fields you need for a new record.
  • If another Zap creates your record and is running after your affected step, add a delay step before your Zapier Tables search action. This will prevent your Zap from running until the record is created.

Adjust the search criteria. 

  • In your affected Zapier Tables action step, adjust the Operator(s) field.
  • Review the number of Lookup fields you are using. This step will find only records that match all lookup fields.

Review the mapped field you are using to lookup records

  • Ensure that the field you mapped provides values that match the record's field in Zapier Tables.
  • If the field you mapped from a previous step does not always send a value, replace it with a field that consistently does. If you do not have a different field:
    • Add a Formatter step to set a default value as a fallback whenever your mapped field has no data.
    • Add a filter or paths before your search step. This will allow you to define what the Zap should do if the mapped field does not receive data from the previous step.
  • If the mapped value comes in a different format than what you use on your table, you can use Formatter by Zapier to match what Zapier Tables contains. Learn more about getting started with Formatter.
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