Google Docs error: Nothing could be found for the search

Symptoms

When using the Google Doc Find Document action in your Zaps, you see the error message "Nothing could be found for the search". You may see this error when setting up a Zap or in the details of a Zap run in your Zap history.

Causes

This happens:

  • The mapped field from the previous step in the Document Name field is blank. 
    • Google Docs require values in the Document Name field to complete the search. 
  • The values in the Document Name field do not exist in Google Docs. 
    • In some cases, the creation of a document depends on another Zap that has not run at the time the search was carried out.

How to fix it

To fix this issue:

  • Ensure the data from the previous step is consistently sent to the Google Docs step, or replace the current mapped field with one that consistently provides a value.
  • If you have a document that exists but is in a different folder than what is selected in the Zap, try reselecting or clearing the Folder field.
  • If you cannot change the current mapped field, you can either:
    • Add a step to set a default value as a fallback whenever your mapped field does not have any data.
    • Add conditional logic using a filter or branching logic with paths to your Zap. This will allow you to define what the Zap should do if the Document Name field receives no data from the previous step.
  • Add a delay to your Zap to add in some time before the Zap searches for the document.
Was this article helpful?
0 out of 0 found this helpful