Symptoms
When setting up your Zap with Facebook Lead Ads, you do not see your Facebook Page in the Page dropdown menu.
Causes
This happens when:
- you manage multiple Facebook Pages.
- you have insufficient account permissions associated with your Facebook page and ad account in Facebook Lead Ads.
How to fix it
To fix this issue:
- If your Facebook Page still does not appear, find the Facebook page ID.
- Set the Page field with the Facebook page ID as a custom value.
- If that doesn't work, it's likely an account permission issue. Upgrade your Facebook Lead Ads account permissions.
- Reconnect your Facebook Lead Ads account in Zapier.