Symptom
You check your Zap History and do not see a new run but you know the trigger event happened on your trigger app.
Causes
This can occur for multiple reasons:
- Your Zap is not turned on.
- The items existed prior to the Zap being turned on.
- There is a connection issue between your app and Zapier.
- The incorrect trigger event was selected.
- The trigger event options do not match the data you're looking for.
How to fix it
Check that the Zap is turned on
In the Zap editor, you can check if the switch on the top left of the screen is on. If not:
- Click the switch to turn the Zap on.
- Test the Zap by creating new data on your app to trigger the event.
If your Zap triggers every time you receive a new email, send yourself a new email to test the Zap.
Check if the data was created before the Zap was turned on
Because of how Zapier works, your Zap will not trigger on existing data. It will only pick up new data. If you want to import existing information from one app to another, you can do a one-time transfer.
Check your trigger app account connection
If you don't see any Zap runs, your Zap may be having trouble connecting to the trigger app. Check if the account is connected and that the connection is working:
- In the Zap editor, click the Trigger step. A dialog box will open.
- Click the Account tab.
- Check if you’re using the correct app account and if the app account is connected to Zapier.
- If the correct app account isn’t connected, click the account dropdown menu and click + Connect a new account.
- If your app account connection is not working, reconnect your app account.
Check that you're using the correct trigger event
Your Zap may be using a trigger that does not pick up the data you're expecting. You can check what the selected event will pick up:
- In the Zap editor, click the Trigger step. A dialog box will open.
- In the App & event tab, check if the correct Event is selected.
For example, if your app differentiates between contacts and leads, and you want the Zap to trigger when new leads are created, make sure that the trigger event is “New Leads” and not “New Contacts”.
Check your trigger options
If your trigger has any additional options, check that they're correctly filled in and set up.
- In the Zap editor, click the Trigger step. A dialog box will open.
- Click the Configure tab (if available) and check each option.
You’ve set a “New Subscriber” trigger to pick up when new subscribers are added to the “ABC list,” but you are actually adding them to the "123 list.” You can update the selected list to ensure the new subscribers will be picked up by the Zap.
Turn the Zap off and on
If none of the previous fixes works for your Zap, you can try turning it off and on, to force it to refresh the data and re-establish a connection to the app.
- In the Zap editor, click the switch to turn the Zap off.
- Click the switch again to turn the Zap back on.
- Test the Zap by sending new data to cause the trigger event to happen.
If you're still unable to identify why your Zap isn't triggering, contact Zapier support.