Symptoms
When you add a new Stripe component to your interface page, an alert appears in the setup dialog box with the message "You need to finish setting up your Stripe account in order to start collecting payments."
Causes
This can happen if:
- You connected your account to Zapier, but Stripe requires you to add more information to your Stripe account.
- You started but did not complete the Stripe connection process and returned to the interface page setup.
How to fix it
To fix this, log in to your Stripe account to see what information is missing. Once you submit all required information, your account will undergo Stripe's verification process.