Symptoms
After my legacy custom action was converted to an API Request action, you may encounter errors mentioning “invalid JSON.” This message can vary depending on the app’s API.
Causes
This happens when double quotes appear in the body of the request, causing the JSON to be invalid.
How to fix it
To fix this issue:
- Go to your affected API Request action step.
- Within the Body field:
- Escape double quotes with a backslash before each one.
- Or, if unnecessary, remove the double quotes entirely.