Google Sheets error: Unable to get a value when looking for "rows". Is it empty or missing?

Symptoms

When using either the Google Sheet Create Spreadsheet Row or Create Multiple Spreadsheet Rows action, you see the error message "Unable to get a value when looking for "rows". Is it empty or missing?". 

This error will appear in the Zap editor when testing Zap steps or in Zap history after your Zap runs. The Zap run status will display as stopped.

Causes

This happens when: 

  • Headers are not in the first row of the spreadsheet.
  • The mapped fields from the previous step were blank when the Zap ran or was tested, and are required for the action to create a row. 
  • The mapped fields are not in line item format when using the Create Multiple Spreadsheets Rows action. 

How to fix it

To fix the issue:

  • Ensure headers are added to the first row only of your spreadsheet. Learn more about spreadsheet formatting for using Google Sheets with Zapier.
  • Ensure the data from the previous step is consistently sent to the currently mapped field, or replace the mapped field with one that consistently provides a value.
  • If you cannot change the current mapped field, you can either:
    • Add a step to set a default value as a fallback whenever your mapped field does not have data.
    • Add conditional logic using a filter or branching logic with paths to your Zap. This will allow you to set what the Zap should do if your mapped value contains no value.
  • If you are using the Create Multiple Spreadsheet Rows action:
    • Check if this is the correct action for your data. If the previous step only sends single record each time, use the Create Spreadsheet Row action instead.
    • If your previous step sends multiple records but they're not in a line item format, use a Formatter step to format this data as line items.
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