This guide will describe what errors can occur when creating chatbots in Zapier Interfaces and how to resolve them.
context_length_exceeded
Problem
The chat conversation has reached the maximum amount of tokens the OpenAI model allows.
Cause
Although chatbots automatically reset token usage whenever a conversation is close to the token limit, at times, the conversation thread or directive's size may still reach the tokens' limit.
Resolution
In your Interfaces chatbot settings:
- Decrease your setting for max response length (tokens) per response.
- Shorten your directive.
- Add your own OpenAI key to your chatbot and use a model with a larger token limit, such as GPT-4.

- There's no character limit for directives, but keep directives brief and organized to ensure they work well.
- Token limits are per conversation, but the length of the directive, the length of the questions, and the length of the response all use tokens within that conversation.
max_completion_limit
Problem
The chatbot's individual response has exceeded the max token limit set.
Cause
This error can happen if the user asks for a response that requires a large number of tokens. For example: "Write me a 10-chapter book" or if you've set your max response length to a small max limit.
Resolution
In your Interfaces chatbot settings:
- Increase your max response length (tokens) per response.
- Specify simplified response goals within your directive.
- Add your own OpenAI key to your chatbot and use a model with a larger token limit, such as GPT-4.
timeout
Problem
Zapier didn’t get a response from OpenAI within 10 seconds of your prompt being sent.
Cause
OpenAI struggles to keep up with requests or the general network is slow.
Resolution
Review OpenAI’s status page and try utilizing your chatbot again later.
internal_server_error
Problem
Communication between Zapier and other service providers isn’t working as expected.
Cause
The cause of this error is unknown.
Resolution
Contact Interfaces Support, as this is likely a bug you’re running into.
unknown
Problem
Zapier can’t extract a standard error code so the cause of this error is unknown.
Cause
The cause of this error is unknown.
Resolution
Contact Interfaces Support, as this is likely a bug you’re running into.